• UbuCon Latinoamérica 2016
  • Ubuntu Phone
  • Rápido, seguro, libre e increíblemente fácil de usar
  • Ubuntu: Linux para seres humanos
  • Linux es Educación. Linux es Ciencia
  • Ubuntu es diseño, Ubuntu es innovación
  • Ubuntu León semper plus ultra
  • Keep calm and enjoy Ubuntu
  • Usa el teclado como se merece con el Dash de Ubuntu
  • pf-kernel para Ubuntu
  • Convierte tu iMac en un ordenador de verdad
  • Unity. Al fin un escritorio ordenado
  • Software libre, para una sociedad libre

Correcciones menores (pero muy molestas).

Entrada escrita por: Francisco Javier Teruelo de Luis
Buenas.

Tengo por costumbre ampliar el software disponible, y eso incluye PPAs y repositorios no canonicos; un verdadero dolor de cabeza con los cambios de versión.

Pero a veces no hace falta ni cambiar de versión. Hace poco os habréis encontrado con ésto:

Imposible obtener http://dl.google.com/linux/chrome/deb/dists/stable/Release  No se pudo encontrar la entrada esperada «main/binary-i386/Packages» en el archivo «Release» (entrada incorrecta en «sources.list» o fichero mal formado)

Tanto en 32 como en 64 bits. El origen del problema es que Google ha suspendido el mantenimiento de la versión de 32 bits (por fuente secundaria, aquí). No me supone un problema porque no tiendo a utilizarlo, pero es un paso más en la condena a la maquinaria de 32 puesto que mucha gente parece asociar Google Chrome a acceso a internet.

La versión de 64 bits y Chromium continúan sin problemas, pero para que el mensaje desaparezca nos vemos obligados a una modificación manual:

  • Editar el fichero /etc/apt/sources.list.d/google-chrome.list.
  • Encontraremos el siguiente contenido:
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main

  • Añadimos el parámetro [arch=amd64] con lo que el fichero quedará de la siguiente forma:
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

Ya está, ya no pedirá nunca más la versión de 32 bits. Un problema menos.

Por otro lado, el tema del VLC y los DVD originales con encriptación me ha llevado a hacer un proceso por defecto en cada máquina nueva, pero el repositorio puede haber empezado a daros problemas últimamente  si lo tenéis con el siguiente formato:

Fichero: /etc/apt/sources.list.d/libdvdcss.list 

Contenido: deb ftp://ftp.videolan.org/pub/debian/stable ./

 Ahora os encontraréis con este error:
Imposible obtener ftp://ftp.videolan.org/pub/debian/stable/./Release.gpg  No pude conectar un socket pasivo. [IP: 88.191.250.2 21]
Para solventarlo, substituímos el contenido por:
deb http://download.videolan.org/pub/debian/stable /
deb-src http://download.videolan.org/pub/debian/stable/ /
Y ya por si acaso y para aseguraros que no os dé disgustos, lanzáis ésto:

sudo /usr/share/doc/libdvdread4/install-css.sh

Con un poco de suerte, se os acabaron los problemas con los dvd y con los repositorios durante un tiempo.

Hasta luego.

Artículos relacionados