• Rápido, seguro, libre e increíblemente fácil de usar
  • Ubuntu: Linux para seres humanos
  • Linux es Educación. Linux es Ciencia
  • Ubuntu es diseño, Ubuntu es innovación
  • Ubuntu León semper plus ultra
  • Keep calm and enjoy Ubuntu
  • Usa el teclado como se merece con el Dash de Ubuntu
  • pf-kernel para Ubuntu
  • Convierte tu iMac en un ordenador de verdad
  • Unity. Al fin un escritorio ordenado
  • Software libre, para una sociedad libre

El monitor de sistema Conky y Ubuntu 12.04 no se llevan demasiado bien: haz las paces por ellos

Entrada escrita por: Fernando Lanero Barbero
Desde la última versión estable de Ubuntu, Precise Pangolín, los que estamos acostumbrados a monitorizar nuestro sistema a través de Conky, nos hemos encontrado con una innumerable cantidad de bugs corriendo Conky sobre Unity 5.0 (entrono de escritorio por defecto en Ubuntu 12.04).



Muchos de los que usáis Conky en la versión que viene por defecto en los repositorios de Ubuntu (1.9.0) os habréis topado con este mensaje arrojado por la terminal cuando ejecutamos el monitor de sistema desde la misma:

Violación de segmento (`core' generado)
Sobre todo cuando Conky necesita obtener datos desde internet para mostrar en pantalla (como información metereológica, por ejemplo).


La única solución (por ahora) pasa por desistalar por completo la versión actual que tengáis instalada en vuestro equipo:

sudo apt-get remove conky

E instalar una versión optimizada específicamente para Unity 5.0:

sudo add-apt-repository ppa:vincent-c/conky

sudo apt-get update

sudo apt-get install conky-all

A partir de ahora, todo volverá a la más absoluta normalidad :)

Artículos relacionados



1 comentarios:

Yoms Yoms dijo...

¡Funcionó!
Llevaba todo el verano con un problema de lo más extraño. Me había creado dos scripts de Conky, uno que mostraba datos de mi PC y otro información del clima. Ambos funcionaban al cargarlos manualmente o desde scripts shell, pero el del clima no cargaba durante el arranque hiciera lo que hiciera, y sin mostrar ningún mensaje de error.

Tras una actualización rutinaria seguía sin funcionar, pero al menos al intentar cargarlo manualmente me mostraba el error "Violación de segmento". Buscando sobre este error llegué a esta guía, y gracias a ella todo funciona como debería.
Eso sí, no funcionó a la primera: los pasos que das son para desinstalar el paquete "conky", pero el que yo tenía era el "conky-all", que no se desinstaló. Tras percatarme del error lo desinstalé desde Synaptics, volví a seguir los pasos (por si acaso) y al fin funciona.
Ah, y no sólo es para Unity; en mi caso estoy usando LXDE con Openbox en una distro LXLE (basada en Ubuntu 12.04), me he encontrado con el mismo problema y la solución ha sido la misma.